{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:b735696f-3b38-51de-95ac-eb1fbd9052f4",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "spring-graphql",
      "purl": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6",
      "type": "library",
      "group": "org.springframework.graphql",
      "bom-ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6",
      "version": "1.0.6-tuxcare.6",
      "pedigree": {
        "ancestors": [
          {
            "name": "spring-graphql",
            "purl": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6",
            "type": "library",
            "group": "org.springframework.graphql",
            "version": "1.0.6"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2026-41699",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:e565994f-543d-5bf9-bf04-cc3c953b216f",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41699 does not affect version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql. Version 1.0.6 is not vulnerable to CVE-2026-41699. The vulnerable JsonKeysetCursorStrategy class with unsafe PolymorphicTypeValidator was introduced in version 1.2.9, which is later than this version. The keyset/scroll pagination feature that enables unsafe deserialization does not exist in version 1.0.6.",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-41700",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:8398bc79-56d9-5e68-9664-6b86dfbd49ad",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-41700 is fixed in version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    },
    {
      "id": "CVE-2026-41856",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:6b3a074c-e332-5d0c-99af-d3b10d57b1a9",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-41856 is fixed in version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    },
    {
      "id": "CVE-2026-59285",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:b524cc2f-3196-5504-b398-2ca2c2a412de",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59285 affects version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    },
    {
      "id": "CVE-2026-59286",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:4b0c16c9-61eb-5022-a5cb-5389c20ec6de",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-59286 is fixed in version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    },
    {
      "id": "CVE-2026-59287",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:74003642-1d1f-5da9-b4b6-0b5832536398",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-59287 does not affect version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql. not_affected \u2014 Version 1.0.6 is NOT affected by CVE-2026-59287. The vulnerability requires the keepAlive feature to be enabled on WebSocketGraphQlClient, but this feature does not exist in version 1.0.6. The keepAlive functionality was introduced in later versions (1.3.x+). Without the ability to configure or process keepAlive intervals, the vulnerability pattern (orphaned Flux.interval subscriptions leading ...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-59288",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:34e4dc8f-6eda-56c0-951f-38f71ccc2fc4",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-59288 is fixed in version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    },
    {
      "id": "CVE-2026-59289",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:50b6e388-5190-56f4-adc6-bfa145daef2e",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59289 affects version 1.0.6-tuxcare.6 of org.springframework.graphql:spring-graphql."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:maven/org.springframework.graphql/spring-graphql@1.0.6-tuxcare.6"
    }
  ]
}