{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:3bb17429-fa02-5959-9719-19f10e87e214",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "spring-security-oauth2-authorization-server",
      "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1",
      "type": "library",
      "group": "org.springframework.security",
      "bom-ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1",
      "version": "1.4.8-tuxcare.1",
      "pedigree": {
        "ancestors": [
          {
            "name": "spring-security-oauth2-authorization-server",
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8",
            "type": "library",
            "group": "org.springframework.security",
            "version": "1.4.8"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-22258",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:faa5fd27-70b3-5eda-bb9c-38f7995c941a",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-22258 affects version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-22752",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:065a9a9d-3d37-5c61-a4d7-fd3e946f638d",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-22752 is fixed in version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-41008",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:e2877157-17a4-5383-920c-d1dc906ad400",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41008 does not affect version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-47877",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:fdf930d6-11c4-576b-9eb4-81fe7228f693",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-47877 affects version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59316",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:967961e8-ea6e-5a54-aa57-52d0567ee9eb",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59354",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:d43a5517-8786-5687-a7c3-9070d36f606b",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59354 affects version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59355",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:58bde6df-afd8-5e28-953e-9424482bd92f",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-59355 does not affect version 1.4.8-tuxcare.1 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Version 1.4.8 does not process the request_uri parameter that is central to CVE-2026-59355. The vulnerability requires both request_uri processing (to trigger validation errors) and direct query parameter extraction to create an open redirect condition. Since PAR (Pushed Authorization Request) support, which introduced request_uri handling, was added after version 1.4.8, the specific attack pat...",
        "justification": "code_not_present"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.1"
    }
  ]
}