{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:2cf6c34e-8661-5b5c-aef0-f10fcb0de40b",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "spring-security-oauth2-authorization-server",
      "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2",
      "type": "library",
      "group": "org.springframework.security",
      "bom-ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2",
      "version": "1.4.8-tuxcare.2",
      "pedigree": {
        "ancestors": [
          {
            "name": "spring-security-oauth2-authorization-server",
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8",
            "type": "library",
            "group": "org.springframework.security",
            "version": "1.4.8"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-22258",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:2e0df869-a00c-5cd1-815f-d3fb7e993703",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-22258 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-22752",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:13ca5ed1-8fdd-5ef3-82a3-934b8fa984c8",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-22752 is fixed in version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-41008",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:7056b563-72ca-5fbf-bd9c-3091aa563bd8",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41008 does not affect version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-47877",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:23e2d6b9-9af6-5142-af35-3d15d765217e",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-47877 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59316",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:bebbe891-fff2-5853-b9ca-91eb00f9006c",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59354",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:14d21bc2-d0d8-551f-96ae-46c35e026563",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59354 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59355",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
        }
      ],
      "bom-ref": "urn:uuid:75919c15-7eb5-5421-8def-91a0d8cce677",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-59355 does not affect version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Version 1.4.8 does not process the request_uri parameter that is central to CVE-2026-59355. The vulnerability requires both request_uri processing (to trigger validation errors) and direct query parameter extraction to create an open redirect condition. Since PAR (Pushed Authorization Request) support, which introduced request_uri handling, was added after version 1.4.8, the specific attack pat...",
        "justification": "code_not_present"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
    }
  ]
}