{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:b34f99b4-c573-59c0-91ff-1e505a98479b",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "spring-security-oauth2-authorization-server",
      "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
      "type": "library",
      "group": "org.springframework.security",
      "bom-ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
      "version": "1.4.8-tuxcare.3",
      "pedigree": {
        "ancestors": [
          {
            "name": "spring-security-oauth2-authorization-server",
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8",
            "type": "library",
            "group": "org.springframework.security",
            "version": "1.4.8"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-22258",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:966e0847-56b9-5ed1-b9e6-103226d25e1a",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-22258 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-22752",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:cdcab461-c47e-54a1-bddc-d406052c80a1",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-22752 is fixed in version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-41008",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:38980ba2-7037-5c1c-a658-7a7ccd398812",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41008 does not affect version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-47877",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:1048b9ca-7d33-56a7-9a95-f6450ec4de70",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-47877 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59316",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:08576871-955e-5737-8a89-4a2da71c80c7",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59354",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:862a5b8a-aa49-563a-8221-252a23da4bf9",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-59354 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
      }
    },
    {
      "id": "CVE-2026-59355",
      "affects": [
        {
          "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
        }
      ],
      "bom-ref": "urn:uuid:c0218f02-ea25-56d3-9982-d25c1595872e",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-59355 does not affect version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Version 1.4.8 does not process the request_uri parameter that is central to CVE-2026-59355. The vulnerability requires both request_uri processing (to trigger validation errors) and direct query parameter extraction to create an open redirect condition. Since PAR (Pushed Authorization Request) support, which introduced request_uri handling, was added after version 1.4.8, the specific attack pat...",
        "justification": "code_not_present"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
    }
  ]
}