{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:7779b78d-21d0-5343-9c73-b43fefed8e3e",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "@angular/http",
      "purl": "pkg:npm/%40angular/http@8.0.3-tuxcare.8",
      "type": "library",
      "bom-ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8",
      "version": "8.0.3-tuxcare.8",
      "pedigree": {
        "ancestors": [
          {
            "name": "@angular/http",
            "purl": "pkg:npm/%40angular/http@8.0.3",
            "type": "library",
            "version": "8.0.3"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2026-101895",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:f301ea22-7f60-5b3d-a419-7a994c5546e6",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-101895 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-101896",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:ce02830d-481e-55be-8e5d-9b246c4c7e35",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-101896 affects version 8.0.3-tuxcare.8 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-41423",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:eaef58fa-2065-5e62-b781-7ce779b62ed3",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41423 does not affect version 8.0.3-tuxcare.8 of @angular/http. not_affected \u2014 The target Angular version 8.0.3 is not affected by CVE-2026-41423. The vulnerability requires WHATWG URL API (introduced in Angular 8.2.x+) to manifest the hostname override behavior. Version 8.0.3 uses Node.js legacy url.parse() which does not interpret protocol-relative URLs as having attacker-controlled hostnames.",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-46417",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:2c23d183-d6e9-52e9-9257-cf45a11cbe82",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-46417 is fixed in version 8.0.3-tuxcare.8 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50168",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:af82b52a-1b2d-5d89-9092-b95ba9f6c1c4",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50168 is fixed in version 8.0.3-tuxcare.8 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50169",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:73edc1e2-cb8e-592e-a527-df902a9b087b",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50169 is fixed in version 8.0.3-tuxcare.8 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50184",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:56f26304-e9da-525a-9038-f3ad2558ede4",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50184 is fixed in version 8.0.3-tuxcare.8 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50555",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:6706e22b-1fe2-53a6-a71b-22a407964a78",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-50555 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-50556",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:553672eb-8d4b-556f-8323-f9f5c03f08e0",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-50556 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-54264",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:b66feb01-b0f5-5e5a-9157-1356c3209087",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-54264 does not affect version 8.0.3-tuxcare.8 of @angular/http. not_affected \u2014 The target Angular service-worker version 8.0.3-tuxcare.4 is NOT AFFECTED by CVE-2026-54264. The vulnerability requires the service worker to copy and forward request headers during cross-origin redirects. This version never copies headers: the AssetGroup path creates fresh requests from URLs only (no header preservation), and the DataGroup path delegates to the browser's spec-compliant fetch A...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-69149",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:e06850dd-a52b-5f97-b4e4-7f3175d2e7aa",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-69149 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-88056",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:de69b1e0-3b93-515f-87e1-0bed7b41d545",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-88056 does not affect version 8.0.3-tuxcare.8 of @angular/http. not_affected \u2014 Angular 8.0.3 is not affected by CVE-2026-88056. The vulnerability exists only in later Angular versions (v19+, v20+, v21+, v22+) where packages/platform-server/src/url.ts contains a parseUrl function that calls String.prototype.trim() on URL strings. This trim() call strips Unicode whitespace (U+00A0, U+FEFF), converting same-origin URLs into cross-origin protocol-relative URLs, causing SSRF. ...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-88058",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:01e99203-197f-5b76-9372-eb1860286879",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-88058 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-88060",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:709e9699-1546-5a22-b642-6317370461cc",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-88060 affects version 8.0.3-tuxcare.8 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.8"
    }
  ]
}