{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:fd207a39-3fd5-5c72-aec6-0128de6e18d6",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "@angular/http",
      "purl": "pkg:npm/%40angular/http@8.0.3-tuxcare.9",
      "type": "library",
      "bom-ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9",
      "version": "8.0.3-tuxcare.9",
      "pedigree": {
        "ancestors": [
          {
            "name": "@angular/http",
            "purl": "pkg:npm/%40angular/http@8.0.3",
            "type": "library",
            "version": "8.0.3"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2026-101895",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:d328b31a-a0e7-5fe4-b76c-100bb7baa9b6",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-101895 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-101896",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:0a5c65ac-4754-568c-8fa7-c5a9f316ab5a",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-101896 affects version 8.0.3-tuxcare.9 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-41423",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:e139ab22-1451-5cd1-9685-5c6f6f0479b1",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-41423 does not affect version 8.0.3-tuxcare.9 of @angular/http. not_affected \u2014 The target Angular version 8.0.3 is not affected by CVE-2026-41423. The vulnerability requires WHATWG URL API (introduced in Angular 8.2.x+) to manifest the hostname override behavior. Version 8.0.3 uses Node.js legacy url.parse() which does not interpret protocol-relative URLs as having attacker-controlled hostnames.",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-46417",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:d33d4e1e-5c75-5032-a7bf-68eae2e23618",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-46417 is fixed in version 8.0.3-tuxcare.9 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50168",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:c93046c5-464b-5366-b4ad-c4d9e59fe95d",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50168 is fixed in version 8.0.3-tuxcare.9 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50169",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:bd61d916-8da9-5a7a-ae4a-1f5a4499aea7",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50169 is fixed in version 8.0.3-tuxcare.9 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50184",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:2f720d3f-fe9c-5720-911e-f6aaf5c31bf3",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50184 is fixed in version 8.0.3-tuxcare.9 of @angular/http."
      }
    },
    {
      "id": "CVE-2026-50555",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:8ef4e912-7294-5b90-9af2-8d3c0dfbbb38",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-50555 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-50556",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:b8362c8b-2369-5565-9df2-4b69cba12da6",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-50556 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-54264",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:f25fa290-de54-5e3b-8065-5181541bad56",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-54264 does not affect version 8.0.3-tuxcare.9 of @angular/http. not_affected \u2014 The target Angular service-worker version 8.0.3-tuxcare.4 is NOT AFFECTED by CVE-2026-54264. The vulnerability requires the service worker to copy and forward request headers during cross-origin redirects. This version never copies headers: the AssetGroup path creates fresh requests from URLs only (no header preservation), and the DataGroup path delegates to the browser's spec-compliant fetch A...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-69149",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:60aacf8d-2781-53d6-83b3-5d547d4a3524",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-69149 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-88056",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:f1dffa97-829b-5026-8285-4fb5af382edf",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-88056 does not affect version 8.0.3-tuxcare.9 of @angular/http. not_affected \u2014 Angular 8.0.3 is not affected by CVE-2026-88056. The vulnerability exists only in later Angular versions (v19+, v20+, v21+, v22+) where packages/platform-server/src/url.ts contains a parseUrl function that calls String.prototype.trim() on URL strings. This trim() call strips Unicode whitespace (U+00A0, U+FEFF), converting same-origin URLs into cross-origin protocol-relative URLs, causing SSRF. ...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-88058",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:15d614df-1901-5192-a25b-bffd4521554b",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-88058 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    },
    {
      "id": "CVE-2026-88060",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
        }
      ],
      "bom-ref": "urn:uuid:e8eae1d8-f5d6-5aa6-a2f5-5949e3513791",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-88060 affects version 8.0.3-tuxcare.9 of @angular/http, and is fixed in 8.0.3-tuxcare.10."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/%40angular/http@8.0.3-tuxcare.9"
    }
  ]
}