{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:e90e29f8-9531-5354-9690-e7f2e968feac",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "@angular/language-service",
      "purl": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17",
      "type": "library",
      "bom-ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17",
      "version": "9.1.13-tuxcare.17",
      "pedigree": {
        "ancestors": [
          {
            "name": "@angular/language-service",
            "purl": "pkg:npm/%40angular/language-service@9.1.13",
            "type": "library",
            "version": "9.1.13"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2026-101895",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:fa952eac-ddee-598a-807c-b2b8780622cf",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-101895 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-101896",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:9b28fa79-2373-5b56-8da1-d4078b841d27",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2026-101896 affects version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-41423",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:62a33b0d-1cee-56ab-b15a-24920d294188",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-41423 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-46417",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:80aaacde-971a-57e0-955a-e62376970414",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-46417 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-50168",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:d2b92afd-d4c6-5c62-ab18-272b094e8a6a",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50168 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-50169",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:e1c47281-4fcc-50cf-a1dc-4e47c5f7cd0f",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50169 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-50184",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:868440d0-9cca-50ee-83a9-02930a512f98",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50184 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-50555",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:9971b547-edf3-5806-8eb7-26bd6f61a77e",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50555 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-50556",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:5642837a-02bf-58c1-890d-2a9d255bb538",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-50556 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-54264",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:17fc48ae-734a-53c0-a871-a3e589b698a3",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-54264 does not affect version 9.1.13-tuxcare.17 of @angular/language-service. not_affected \u2014 Angular 9.1.13 is not affected by CVE-2026-54264. The target repository uses a fundamentally different request reconstruction architecture than the vulnerable upstream versions (22.0+). The vulnerability requires the presence of header-copying logic during request reconstruction, which does not exist in this version.",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-69149",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:252a69f3-3a9f-52fe-b19e-a2628c2b4e8c",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-69149 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-88056",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:ea0e22cf-e205-50a7-a963-9f5e0ee4199a",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-88056 does not affect version 9.1.13-tuxcare.17 of @angular/language-service. not_affected \u2014 Angular 9.1.13 is not affected by CVE-2026-88056. The vulnerability requires String.prototype.trim() to be called on URLs during server-side rendering, which strips Unicode whitespace and transforms same-origin relative paths into cross-origin protocol-relative URLs. This vulnerable pattern was introduced in Angular v22.0.0-rc.2 (May 2026, commit 6e71049021) as part of a URL resolution refactor...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-88058",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:421c99ab-2c90-55bd-94c5-6f98caca6882",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-88058 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    },
    {
      "id": "CVE-2026-88060",
      "affects": [
        {
          "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
        }
      ],
      "bom-ref": "urn:uuid:313c4e94-b570-5ac0-bb19-6ead0e2e2198",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-88060 is fixed in version 9.1.13-tuxcare.17 of @angular/language-service."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/%40angular/language-service@9.1.13-tuxcare.17"
    }
  ]
}