{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:eae09e97-0218-5105-ad08-6eace0ee8420",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "@vitejs/plugin-legacy",
      "purl": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6",
      "type": "library",
      "bom-ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6",
      "version": "3.2.11-tuxcare.6",
      "pedigree": {
        "ancestors": [
          {
            "name": "@vitejs/plugin-legacy",
            "purl": "pkg:npm/%40vitejs/plugin-legacy@3.2.11",
            "type": "library",
            "version": "3.2.11"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-23331",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:69ea4d0d-0e06-5667-bec8-d359c2e0fd46",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-23331 affects version 3.2.11-tuxcare.6 of @vitejs/plugin-legacy."
      }
    },
    {
      "id": "CVE-2024-31207",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:02d18047-d272-5449-8b06-e46e1f4de3dd",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2024-31207 does not affect version 3.2.11-tuxcare.6 of @vitejs/plugin-legacy. Version 3.2.11 is not vulnerable. Summary: The target repository (Vite v3.2.11) is NOT vulnerable to CVE-2024-31207. The vulnerability was introduced in v3.2.0 (commit df560b02d, 2022-09-22) and fixed in v3.2.9 (commit 89c7c645f, 2024-03-24). The current version includes the complete fix that properly handles server.fs.deny patterns with directories. [terminalized not_affected from patch_application_manual/not_vulnerable]",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2024-45811",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:2751aa67-92ab-569d-9108-53a026c8c7d0",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-45811 affects version 3.2.11-tuxcare.6 of @vitejs/plugin-legacy."
      }
    },
    {
      "id": "CVE-2026-39363",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:6b8548c8-7106-5d19-938c-f16beade62c8",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-39363 does not affect version 3.2.11-tuxcare.6 of @vitejs/plugin-legacy. Version 3.2.11 is not vulnerable. Summary: Target repository (Vite 3.2.11-tuxcare.1) predates the introduction of the vulnerable feature. The fetchModule method exposed via WebSocket (vite:invoke event) does not exist in this version. [terminalized not_affected from patch_application_manual/not_vulnerable]",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-39364",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
        }
      ],
      "bom-ref": "urn:uuid:abbdcdaf-9ea3-5960-a97c-d456061edb7c",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-39364 does not affect version 3.2.11-tuxcare.6 of @vitejs/plugin-legacy. CVE-2026-39364 affects Vite versions 7.1.0 through 7.3.1 and 8.0.0 through 8.0.4. Version 3.2.11 predates the vulnerable architecture introduced in v7.1.0. The v3.2.11 codebase already strips query parameters via fsPathFromUrl()->cleanUrl() before checking server.fs.deny patterns, preventing the bypass described in the CVE. The attack chain (module IDs with query parameters bypassing deny checks) requires the v7+ architecture and does not apply to the older v3.2.11 implementation.",
        "justification": "code_not_present"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.6"
    }
  ]
}