{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:09c5ad1e-dc4a-543e-bb36-a01efc7aa692",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "@vitejs/plugin-legacy",
      "purl": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8",
      "type": "library",
      "bom-ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8",
      "version": "3.2.11-tuxcare.8",
      "pedigree": {
        "ancestors": [
          {
            "name": "@vitejs/plugin-legacy",
            "purl": "pkg:npm/%40vitejs/plugin-legacy@3.2.11",
            "type": "library",
            "version": "3.2.11"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-23331",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:98a46107-2b0c-59f4-b37b-15bbf5435fa6",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-23331 affects version 3.2.11-tuxcare.8 of @vitejs/plugin-legacy."
      }
    },
    {
      "id": "CVE-2024-31207",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:d28d73ac-34f6-5a8d-920c-a09063b7c10b",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2024-31207 does not affect version 3.2.11-tuxcare.8 of @vitejs/plugin-legacy. Version 3.2.11 is not vulnerable. Summary: The target repository (Vite v3.2.11) is NOT vulnerable to CVE-2024-31207. The vulnerability was introduced in v3.2.0 (commit df560b02d, 2022-09-22) and fixed in v3.2.9 (commit 89c7c645f, 2024-03-24). The current version includes the complete fix that properly handles server.fs.deny patterns with directories. [terminalized not_affected from patch_application_manual/not_vulnerable]",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2024-45811",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:8c98b978-dce1-539e-a7b4-dd3b87dc6f40",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-45811 affects version 3.2.11-tuxcare.8 of @vitejs/plugin-legacy."
      }
    },
    {
      "id": "CVE-2026-39363",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:bc3b3e7a-5fa8-5adf-89b8-c4c1773126c5",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-39363 does not affect version 3.2.11-tuxcare.8 of @vitejs/plugin-legacy. Version 3.2.11 is not vulnerable. Summary: Target repository (Vite 3.2.11-tuxcare.1) predates the introduction of the vulnerable feature. The fetchModule method exposed via WebSocket (vite:invoke event) does not exist in this version. [terminalized not_affected from patch_application_manual/not_vulnerable]",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2026-39364",
      "affects": [
        {
          "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
        }
      ],
      "bom-ref": "urn:uuid:ba82c6ee-ae95-5b26-9cc8-cd0d8cbe3c94",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-39364 does not affect version 3.2.11-tuxcare.8 of @vitejs/plugin-legacy. CVE-2026-39364 affects Vite versions 7.1.0 through 7.3.1 and 8.0.0 through 8.0.4. Version 3.2.11 predates the vulnerable architecture introduced in v7.1.0. The v3.2.11 codebase already strips query parameters via fsPathFromUrl()->cleanUrl() before checking server.fs.deny patterns, preventing the bypass described in the CVE. The attack chain (module IDs with query parameters bypassing deny checks) requires the v7+ architecture and does not apply to the older v3.2.11 implementation.",
        "justification": "code_not_present"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/%40vitejs/plugin-legacy@3.2.11-tuxcare.8"
    }
  ]
}