{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:6fb8937e-38f7-5fcf-821b-64c601768930",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "numpy",
      "purl": "pkg:pypi/numpy@1.15.4.post3+tuxcare",
      "type": "library",
      "bom-ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare",
      "version": "1.15.4.post3+tuxcare",
      "pedigree": {
        "ancestors": [
          {
            "name": "numpy",
            "purl": "pkg:pypi/numpy@1.15.4",
            "type": "library",
            "version": "1.15.4"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2014-1858",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:56efe080-3ba3-51f2-a8e1-7ef9b151663c",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1858 does not affect version 1.15.4.post3+tuxcare of numpy. not_affected \u2014 CVE-2014-1858 is NOT present in NumPy 1.15.4. The vulnerability involved insecure use of tempfile.mktemp() in numpy/f2py/__init__.py and numpy/f2py/f2py2e.py, which allowed local users to conduct symlink attacks on predictable temporary filenames. The fix (commit 0bb46c1448) replaced mktemp() with secure alternatives: NamedTemporaryFile() and mkdtemp() which atomically create files/directories....",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2014-1859",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:51b1898d-c4e1-5ff1-8165-68a492c958be",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1859 does not affect version 1.15.4.post3+tuxcare of numpy. not_affected \u2014 NumPy 1.15.4 is not affected by CVE-2014-1859. The original vulnerability (insecure mktemp usage allowing symlink attacks) was fixed by upstream in February 2014 before the 1.8.1 release. Production f2py code uses secure methods (NamedTemporaryFile/mkdtemp). Test code uses mktemp within mkdtemp()-created directories with 0o700 permissions, providing runtime protection against the CVE's cross-us...",
        "justification": "protected_at_runtime"
      }
    },
    {
      "id": "CVE-2017-12852",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:21abcead-fa24-51e6-83f3-abaf572705a0",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2017-12852 affects version 1.15.4.post3+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2019-6446",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:3394b4a4-bd54-54a6-bbe4-a1afd39f9b43",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2019-6446 is fixed in version 1.15.4.post3+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-33430",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:4033a56e-2ffd-58ba-a0db-2ac98e3d6e6d",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2021-33430 affects version 1.15.4.post3+tuxcare of numpy, and is fixed in 1.15.4.post4+tuxcare."
      }
    },
    {
      "id": "CVE-2021-34141",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:7f8615c2-3abe-5c18-a2da-2e489a53795c",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-34141 is fixed in version 1.15.4.post3+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41495",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:91829845-bf4e-5e1b-a6ac-ff6e6c2a10fc",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-41495 is fixed in version 1.15.4.post3+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41496",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:e45e1770-4011-56ac-b79d-8638b4a48389",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2021-41496 affects version 1.15.4.post3+tuxcare of numpy, and is fixed in 1.15.4.post5+tuxcare."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:pypi/numpy@1.15.4.post3+tuxcare"
    }
  ]
}