{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:bca6fc19-8772-581b-9536-8826a6ac5f42",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "numpy",
      "purl": "pkg:pypi/numpy@1.15.4.post4+tuxcare",
      "type": "library",
      "bom-ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare",
      "version": "1.15.4.post4+tuxcare",
      "pedigree": {
        "ancestors": [
          {
            "name": "numpy",
            "purl": "pkg:pypi/numpy@1.15.4",
            "type": "library",
            "version": "1.15.4"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2014-1858",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:47748e38-935c-5ea4-9976-ad48980c52bf",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1858 does not affect version 1.15.4.post4+tuxcare of numpy. not_affected \u2014 CVE-2014-1858 is NOT present in NumPy 1.15.4. The vulnerability involved insecure use of tempfile.mktemp() in numpy/f2py/__init__.py and numpy/f2py/f2py2e.py, which allowed local users to conduct symlink attacks on predictable temporary filenames. The fix (commit 0bb46c1448) replaced mktemp() with secure alternatives: NamedTemporaryFile() and mkdtemp() which atomically create files/directories....",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2014-1859",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:9c3f1cf8-75ba-5a36-a55b-5d2cec3b1708",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1859 does not affect version 1.15.4.post4+tuxcare of numpy. not_affected \u2014 NumPy 1.15.4 is not affected by CVE-2014-1859. The original vulnerability (insecure mktemp usage allowing symlink attacks) was fixed by upstream in February 2014 before the 1.8.1 release. Production f2py code uses secure methods (NamedTemporaryFile/mkdtemp). Test code uses mktemp within mkdtemp()-created directories with 0o700 permissions, providing runtime protection against the CVE's cross-us...",
        "justification": "protected_at_runtime"
      }
    },
    {
      "id": "CVE-2017-12852",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:3cd8d641-c774-5bea-80f4-189d8b71d672",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2017-12852 affects version 1.15.4.post4+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2019-6446",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:3e6bb7ea-d73e-5f16-b135-06c3414a679b",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2019-6446 is fixed in version 1.15.4.post4+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-33430",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:9025fa9f-f67d-5ce8-a022-fdeb64a611e0",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-33430 is fixed in version 1.15.4.post4+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-34141",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:3dcc0995-69d7-5b35-8548-7c1dbd458183",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-34141 is fixed in version 1.15.4.post4+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41495",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:e6a51c4a-0779-5e08-ac7f-2c997d81969a",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-41495 is fixed in version 1.15.4.post4+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41496",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:7ce8f485-c6bc-5041-835d-70ce90830f23",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2021-41496 affects version 1.15.4.post4+tuxcare of numpy, and is fixed in 1.15.4.post5+tuxcare."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:pypi/numpy@1.15.4.post4+tuxcare"
    }
  ]
}