{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:02f98492-9f12-510f-92ea-9ec5ac69a57a",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "numpy",
      "purl": "pkg:pypi/numpy@1.15.4.post5+tuxcare",
      "type": "library",
      "bom-ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare",
      "version": "1.15.4.post5+tuxcare",
      "pedigree": {
        "ancestors": [
          {
            "name": "numpy",
            "purl": "pkg:pypi/numpy@1.15.4",
            "type": "library",
            "version": "1.15.4"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2014-1858",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:71804735-1c66-57f2-b851-83d037749f8a",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1858 does not affect version 1.15.4.post5+tuxcare of numpy. not_affected \u2014 CVE-2014-1858 is NOT present in NumPy 1.15.4. The vulnerability involved insecure use of tempfile.mktemp() in numpy/f2py/__init__.py and numpy/f2py/f2py2e.py, which allowed local users to conduct symlink attacks on predictable temporary filenames. The fix (commit 0bb46c1448) replaced mktemp() with secure alternatives: NamedTemporaryFile() and mkdtemp() which atomically create files/directories....",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2014-1859",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:c91cb63e-0fae-5b5f-b1ad-20694b4dcab6",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2014-1859 does not affect version 1.15.4.post5+tuxcare of numpy. not_affected \u2014 NumPy 1.15.4 is not affected by CVE-2014-1859. The original vulnerability (insecure mktemp usage allowing symlink attacks) was fixed by upstream in February 2014 before the 1.8.1 release. Production f2py code uses secure methods (NamedTemporaryFile/mkdtemp). Test code uses mktemp within mkdtemp()-created directories with 0o700 permissions, providing runtime protection against the CVE's cross-us...",
        "justification": "protected_at_runtime"
      }
    },
    {
      "id": "CVE-2017-12852",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:5d657592-425d-516d-93e0-63a78d896e23",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2017-12852 affects version 1.15.4.post5+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2019-6446",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:37df0610-1feb-5d01-a9a8-35b860c7f67c",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2019-6446 is fixed in version 1.15.4.post5+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-33430",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:1aea02bc-c965-548f-8bbe-9ca1475a9e38",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-33430 is fixed in version 1.15.4.post5+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-34141",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:9116b510-1b72-55a3-bea0-d2de7e7fbdab",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-34141 is fixed in version 1.15.4.post5+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41495",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:e56886ed-ee7c-580f-a7bf-1ae09aa2398c",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-41495 is fixed in version 1.15.4.post5+tuxcare of numpy."
      }
    },
    {
      "id": "CVE-2021-41496",
      "affects": [
        {
          "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:41d88a1a-4cea-555a-9864-1adc25e799cf",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2021-41496 is fixed in version 1.15.4.post5+tuxcare of numpy."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:pypi/numpy@1.15.4.post5+tuxcare"
    }
  ]
}