{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:cde6f56a-30a1-5556-a014-2da96a461d4e",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "requests",
      "purl": "pkg:pypi/requests@2.32.3.post3+tuxcare",
      "type": "library",
      "bom-ref": "pkg:pypi/requests@2.32.3.post3+tuxcare",
      "version": "2.32.3.post3+tuxcare",
      "pedigree": {
        "ancestors": [
          {
            "name": "requests",
            "purl": "pkg:pypi/requests@2.32.3",
            "type": "library",
            "version": "2.32.3"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2023-32681",
      "affects": [
        {
          "ref": "pkg:pypi/requests@2.32.3.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:ac60f809-6259-5fba-93e8-b22bc7e3f55e",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2023-32681 does not affect version 2.32.3.post3+tuxcare of requests. not_affected \u2014 CVE-2023-32681 (Proxy-Authorization header leak to HTTPS destinations) is not present in target version 2.32.3. The vulnerability was fixed upstream in v2.31.0 via commit 74ea7cf7a6a27a4eeb2ae24e162bcc942a6706d5 by nate.prewitt@gmail.com. The fix prevents attaching Proxy-Authorization headers to HTTPS-destined requests by adding the condition `if not scheme.startswith(\"https\")` in the rebuild_p...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2024-35195",
      "affects": [
        {
          "ref": "pkg:pypi/requests@2.32.3.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:9106744d-686b-5bf1-8ed6-c97c89e48494",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2024-35195 does not affect version 2.32.3.post3+tuxcare of requests. not_affected \u2014 CVE-2024-35195 affects requests versions prior to 2.32.0. The target is at version 2.32.3.post3+tuxcare, which includes the upstream fix from commit c0813a2d (merged in v2.32.0). The fix modifies connection pool selection to include TLS verification settings (cert_reqs, ca_certs), preventing verify=False connections from being reused for verify=True requests. The vulnerable code pattern is not ...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2024-47081",
      "affects": [
        {
          "ref": "pkg:pypi/requests@2.32.3.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:c7db1431-b806-53df-bc9d-10a9f3c99e11",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-47081 is fixed in version 2.32.3.post3+tuxcare of requests."
      }
    },
    {
      "id": "CVE-2026-25645",
      "affects": [
        {
          "ref": "pkg:pypi/requests@2.32.3.post3+tuxcare"
        }
      ],
      "bom-ref": "urn:uuid:213bf3a8-12b0-5170-8601-ef1ec206d250",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2026-25645 is fixed in version 2.32.3.post3+tuxcare of requests."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:pypi/requests@2.32.3.post3+tuxcare"
    }
  ]
}