{
  "@id": "urn:uuid:82e57145-4cc3-4ea5-b9c0-e43fda37c3ae",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 6,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-29T07:42:31.773838+00:00",
  "statements": [
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-29T03:48:46.502543+00:00",
      "status_notes": "Vulnerability CVE-2024-22258 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2024-22258"
      },
      "action_statement": "Vulnerability CVE-2024-22258 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
    },
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-28T14:56:16.229460+00:00",
      "status_notes": "Vulnerability CVE-2026-22752 is fixed in version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-22752"
      }
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-28T14:56:16.229460+00:00",
      "status_notes": "Vulnerability CVE-2026-41008 does not affect version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-41008"
      },
      "impact_statement": "not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-28T18:40:55.741562+00:00",
      "status_notes": "Vulnerability CVE-2026-47877 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-47877"
      },
      "action_statement": "Vulnerability CVE-2026-47877 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-28T14:56:16.229460+00:00",
      "status_notes": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-59316"
      },
      "action_statement": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-28T18:34:10.986929+00:00",
      "status_notes": "Vulnerability CVE-2026-59354 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-59354"
      },
      "action_statement": "Vulnerability CVE-2026-59354 affects version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.3"
          }
        }
      ],
      "timestamp": "2026-10-29T07:42:31.773838+00:00",
      "status_notes": "Vulnerability CVE-2026-59355 does not affect version 1.4.8-tuxcare.3 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Version 1.4.8 does not process the request_uri parameter that is central to CVE-2026-59355. The vulnerability requires both request_uri processing (to trigger validation errors) and direct query parameter extraction to create an open redirect condition. Since PAR (Pushed Authorization Request) support, which introduced request_uri handling, was added after version 1.4.8, the specific attack pat...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-59355"
      },
      "impact_statement": "not_affected \u2014 Version 1.4.8 does not process the request_uri parameter that is central to CVE-2026-59355. The vulnerability requires both request_uri processing (to trigger validation errors) and direct query parameter extraction to create an open redirect condition. Since PAR (Pushed Authorization Request) support, which introduced request_uri handling, was added after version 1.4.8, the specific attack pat..."
    }
  ]
}
