{
  "@id": "urn:uuid:a480cd49-4fc0-4e24-b3c7-f107f8ee68c1",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 6,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-30T00:39:00.143564+00:00",
  "statements": [
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2018-20801 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1.",
      "vulnerability": {
        "name": "CVE-2018-20801"
      },
      "action_statement": "Vulnerability CVE-2018-20801 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2021-29489 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1.",
      "vulnerability": {
        "name": "CVE-2021-29489"
      },
      "action_statement": "Vulnerability CVE-2021-29489 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-30T00:39:00.143564+00:00",
      "status_notes": "Vulnerability CVE-2026-116796 does not affect version 6.0.7 of highcharts. not_affected \u2014 Version 6.0.7 is not affected by CVE-2026-116796. The vulnerability exists in the AST.filterUserAttributes function which was introduced in Highcharts v10.3.2 or later. Version 6.0.7 uses a fundamentally different text processing architecture (buildText with parseAttribute) that only extracts whitelisted attributes (class, style, href) from user markup, completely ignoring xlink:href. The malic...",
      "justification": "vulnerable_code_not_in_execute_path",
      "vulnerability": {
        "name": "CVE-2026-116796"
      },
      "impact_statement": "not_affected \u2014 Version 6.0.7 is not affected by CVE-2026-116796. The vulnerability exists in the AST.filterUserAttributes function which was introduced in Highcharts v10.3.2 or later. Version 6.0.7 uses a fundamentally different text processing architecture (buildText with parseAttribute) that only extracts whitelisted attributes (class, style, href) from user markup, completely ignoring xlink:href. The malic..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118244 affects version 6.0.7 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118244"
      },
      "action_statement": "Vulnerability CVE-2026-118244 affects version 6.0.7 of highcharts."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-30T00:15:00.109831+00:00",
      "status_notes": "Vulnerability CVE-2026-118246 does not affect version 6.0.7 of highcharts. not_affected \u2014 CVE-2026-118246 describes XSS through unfiltered event handler attributes in breadcrumbs.style configuration (affected versions 10.0.0-13.0.2). Highcharts 6.0.7 does not contain the breadcrumbs feature at all - exhaustive searches across all modules (drilldown, treemap, sunburst) found zero references. While the underlying _defaultSetter code pattern (lines 4205-4207) exists without filtering, ...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-118246"
      },
      "impact_statement": "not_affected \u2014 CVE-2026-118246 describes XSS through unfiltered event handler attributes in breadcrumbs.style configuration (affected versions 10.0.0-13.0.2). Highcharts 6.0.7 does not contain the breadcrumbs feature at all - exhaustive searches across all modules (drilldown, treemap, sunburst) found zero references. While the underlying _defaultSetter code pattern (lines 4205-4207) exists without filtering, ..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118249 affects version 6.0.7 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118249"
      },
      "action_statement": "Vulnerability CVE-2026-118249 affects version 6.0.7 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:31.605031+00:00",
      "status_notes": "Vulnerability CVE-2026-118250 affects version 6.0.7 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118250"
      },
      "action_statement": "Vulnerability CVE-2026-118250 affects version 6.0.7 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118251 affects version 6.0.7 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118251"
      },
      "action_statement": "Vulnerability CVE-2026-118251 affects version 6.0.7 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability GHSA-gr4j-r575-g665 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1.",
      "vulnerability": {
        "name": "GHSA-gr4j-r575-g665"
      },
      "action_statement": "Vulnerability GHSA-gr4j-r575-g665 affects version 6.0.7 of highcharts, and is fixed in 6.0.7-tuxcare.1."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.0.7",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.0.7"
          }
        }
      ],
      "timestamp": "2026-10-20T12:46:51.138394+00:00",
      "status_notes": "Vulnerability GHSA-m45f-4828-5cv5 is a false positive for highcharts 6.0.7.",
      "vulnerability": {
        "name": "GHSA-m45f-4828-5cv5"
      },
      "impact_statement": "The vulnerability has been withdrawn."
    }
  ]
}
