{
  "@id": "urn:uuid:18dcc7a8-b34f-4539-9446-e5c464a3860a",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 5,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-30T00:23:00.165122+00:00",
  "statements": [
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2021-29489 is fixed in version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2021-29489"
      }
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:31.605031+00:00",
      "status_notes": "Vulnerability CVE-2026-116796 affects version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-116796"
      },
      "action_statement": "Vulnerability CVE-2026-116796 affects version 6.1.0-tuxcare.1 of highcharts."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-30T00:23:00.165122+00:00",
      "status_notes": "Vulnerability CVE-2026-118244 does not affect version 6.1.0-tuxcare.1 of highcharts. not_affected \u2014 Highcharts 6.1.0 is not affected by CVE-2026-118244. The CVE describes a specific vulnerability in versions 12.0.0-13.0.2 where an AST-based HTML text parser uses DOMParser, which throws during beforeprint handlers in Chromium due to Trusted Types, causing a fallback to innerHTML before an allow-list can filter embedded handlers. Version 6.1.0 lacks this entire architecture: no AST class, no pa...",
      "justification": "vulnerable_code_not_in_execute_path",
      "vulnerability": {
        "name": "CVE-2026-118244"
      },
      "impact_statement": "not_affected \u2014 Highcharts 6.1.0 is not affected by CVE-2026-118244. The CVE describes a specific vulnerability in versions 12.0.0-13.0.2 where an AST-based HTML text parser uses DOMParser, which throws during beforeprint handlers in Chromium due to Trusted Types, causing a fallback to innerHTML before an allow-list can filter embedded handlers. Version 6.1.0 lacks this entire architecture: no AST class, no pa..."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-30T00:12:00.141034+00:00",
      "status_notes": "Vulnerability CVE-2026-118246 does not affect version 6.1.0-tuxcare.1 of highcharts. not_affected \u2014 Highcharts 6.1.0 is not affected by CVE-2026-118246. The vulnerability requires the breadcrumbs feature (introduced in v10.0.0+) which does not exist in version 6.1.0. While the underlying _defaultSetter method exists without event handler filtering, there is no user-accessible code path in v6.1.0 that allows arbitrary attribute keys to reach it in an exploitable manner. The breadcrumbs feature...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-118246"
      },
      "impact_statement": "not_affected \u2014 Highcharts 6.1.0 is not affected by CVE-2026-118246. The vulnerability requires the breadcrumbs feature (introduced in v10.0.0+) which does not exist in version 6.1.0. While the underlying _defaultSetter method exists without event handler filtering, there is no user-accessible code path in v6.1.0 that allows arbitrary attribute keys to reach it in an exploitable manner. The breadcrumbs feature..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118249 affects version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118249"
      },
      "action_statement": "Vulnerability CVE-2026-118249 affects version 6.1.0-tuxcare.1 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:31.605031+00:00",
      "status_notes": "Vulnerability CVE-2026-118250 affects version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118250"
      },
      "action_statement": "Vulnerability CVE-2026-118250 affects version 6.1.0-tuxcare.1 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118251 affects version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118251"
      },
      "action_statement": "Vulnerability CVE-2026-118251 affects version 6.1.0-tuxcare.1 of highcharts."
    },
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/highcharts@6.1.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@6.1.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability GHSA-gr4j-r575-g665 is fixed in version 6.1.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "GHSA-gr4j-r575-g665"
      }
    }
  ]
}
