{
  "@id": "urn:uuid:cef2c959-57c4-4f38-adb6-a41c47ac8adb",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 5,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-30T14:08:00.097700+00:00",
  "statements": [
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2021-29489 is fixed in version 7.2.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2021-29489"
      }
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-30T00:37:00.208496+00:00",
      "status_notes": "Vulnerability CVE-2026-116796 does not affect version 7.2.0-tuxcare.1 of highcharts. not_affected \u2014 Version 7.2.0 is not affected by CVE-2026-116796. The vulnerability requires the AST.filterUserAttributes function introduced in Highcharts 10.3.2+, which does not exist in version 7.2.0. This version uses a fundamentally different architecture that prevents xlink:href attributes from user input from reaching exported SVG through multiple defensive layers: (1) all <a> tags are converted to <spa...",
      "vulnerability": {
        "name": "CVE-2026-116796"
      },
      "impact_statement": "not_affected \u2014 Version 7.2.0 is not affected by CVE-2026-116796. The vulnerability requires the AST.filterUserAttributes function introduced in Highcharts 10.3.2+, which does not exist in version 7.2.0. This version uses a fundamentally different architecture that prevents xlink:href attributes from user input from reaching exported SVG through multiple defensive layers: (1) all <a> tags are converted to <spa..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118244 affects version 7.2.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118244"
      },
      "action_statement": "Vulnerability CVE-2026-118244 affects version 7.2.0-tuxcare.1 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118246 affects version 7.2.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118246"
      },
      "action_statement": "Vulnerability CVE-2026-118246 affects version 7.2.0-tuxcare.1 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-28T20:58:09.118737+00:00",
      "status_notes": "Vulnerability CVE-2026-118249 affects version 7.2.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "CVE-2026-118249"
      },
      "action_statement": "Vulnerability CVE-2026-118249 affects version 7.2.0-tuxcare.1 of highcharts."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-30T14:08:00.097700+00:00",
      "status_notes": "Vulnerability CVE-2026-118250 affects version 7.2.0-tuxcare.1 of highcharts, and is fixed in 7.2.0-tuxcare.2.",
      "vulnerability": {
        "name": "CVE-2026-118250"
      },
      "action_statement": "Vulnerability CVE-2026-118250 affects version 7.2.0-tuxcare.1 of highcharts, and is fixed in 7.2.0-tuxcare.2."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-10-30T14:08:00.097700+00:00",
      "status_notes": "Vulnerability CVE-2026-118251 affects version 7.2.0-tuxcare.1 of highcharts, and is fixed in 7.2.0-tuxcare.2.",
      "vulnerability": {
        "name": "CVE-2026-118251"
      },
      "action_statement": "Vulnerability CVE-2026-118251 affects version 7.2.0-tuxcare.1 of highcharts, and is fixed in 7.2.0-tuxcare.2."
    },
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/highcharts@7.2.0-tuxcare.1",
          "identifiers": {
            "purl": "pkg:npm/highcharts@7.2.0-tuxcare.1"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability GHSA-gr4j-r575-g665 is fixed in version 7.2.0-tuxcare.1 of highcharts.",
      "vulnerability": {
        "name": "GHSA-gr4j-r575-g665"
      }
    }
  ]
}
