{
  "@id": "urn:uuid:ba07a712-5fb8-44cd-bd37-7cf060021e85",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 6,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-29T07:31:18.734944+00:00",
  "statements": [
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-29T07:31:18.734944+00:00",
      "status_notes": "Vulnerability CVE-2014-10064 affects version 6.10.7-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2014-10064"
      },
      "action_statement": "Vulnerability CVE-2014-10064 affects version 6.10.7-tuxcare.2 of qs."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-29T07:31:18.734944+00:00",
      "status_notes": "Vulnerability CVE-2014-7191 affects version 6.10.7-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2014-7191"
      },
      "action_statement": "Vulnerability CVE-2014-7191 affects version 6.10.7-tuxcare.2 of qs."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-29T07:31:18.734944+00:00",
      "status_notes": "Vulnerability CVE-2017-1000048 affects version 6.10.7-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2017-1000048"
      },
      "action_statement": "Vulnerability CVE-2017-1000048 affects version 6.10.7-tuxcare.2 of qs."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-29T07:31:18.734944+00:00",
      "status_notes": "Vulnerability CVE-2022-24999 affects version 6.10.7-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2022-24999"
      },
      "action_statement": "Vulnerability CVE-2022-24999 affects version 6.10.7-tuxcare.2 of qs."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-23T13:58:26.988331+00:00",
      "status_notes": "Vulnerability CVE-2025-15284 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4.",
      "vulnerability": {
        "name": "CVE-2025-15284"
      },
      "action_statement": "Vulnerability CVE-2025-15284 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-14T22:18:00.169151+00:00",
      "status_notes": "Vulnerability CVE-2026-110816 affects version 6.10.7-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2026-110816"
      },
      "action_statement": "Vulnerability CVE-2026-110816 affects version 6.10.7-tuxcare.2 of qs."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-23T13:58:26.988331+00:00",
      "status_notes": "Vulnerability CVE-2026-2391 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4.",
      "vulnerability": {
        "name": "CVE-2026-2391"
      },
      "action_statement": "Vulnerability CVE-2026-2391 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-23T13:58:26.988331+00:00",
      "status_notes": "Vulnerability CVE-2026-82417 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4.",
      "vulnerability": {
        "name": "CVE-2026-82417"
      },
      "action_statement": "Vulnerability CVE-2026-82417 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-23T13:58:26.988331+00:00",
      "status_notes": "Vulnerability CVE-2026-82562 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4.",
      "vulnerability": {
        "name": "CVE-2026-82562"
      },
      "action_statement": "Vulnerability CVE-2026-82562 affects version 6.10.7-tuxcare.2 of qs, and is fixed in 6.10.7-tuxcare.4."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2026-8723 does not affect version 6.10.7-tuxcare.2 of qs. not_affected \u2014 Version 6.10.7 is not affected by CVE-2026-8723. The vulnerable code pattern (encoding array elements before joining) was introduced in version 6.11.1. Version 6.10.7 implements the comma + encodeValuesOnly path differently: it joins the array first (converting null/undefined to empty strings), then encodes the resulting string parts. The encoder never receives null/undefined values and therefo...",
      "justification": "vulnerable_code_not_in_execute_path",
      "vulnerability": {
        "name": "CVE-2026-8723"
      },
      "impact_statement": "not_affected \u2014 Version 6.10.7 is not affected by CVE-2026-8723. The vulnerable code pattern (encoding array elements before joining) was introduced in version 6.11.1. Version 6.10.7 implements the comma + encodeValuesOnly path differently: it joins the array first (converting null/undefined to empty strings), then encodes the resulting string parts. The encoder never receives null/undefined values and therefo..."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.10.7-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.10.7-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-29T07:31:18.734944+00:00",
      "status_notes": "Vulnerability GHSA-crvj-3gj9-gm2p is a false positive for qs 6.10.7-tuxcare.2.",
      "vulnerability": {
        "name": "GHSA-crvj-3gj9-gm2p"
      },
      "impact_statement": "The vulnerability has been withdrawn."
    }
  ]
}
