{
  "@id": "urn:uuid:94f1a645-467f-47f8-8226-ac38b2327149",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 6,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-29T21:37:00.115870+00:00",
  "statements": [
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:pypi/requests@2.32.3.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/requests@2.32.3.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-10-29T21:37:00.115870+00:00",
      "status_notes": "Vulnerability CVE-2023-32681 does not affect version 2.32.3.post1+tuxcare of requests. not_affected \u2014 CVE-2023-32681 (Proxy-Authorization header leak to HTTPS destinations) is not present in target version 2.32.3. The vulnerability was fixed upstream in v2.31.0 via commit 74ea7cf7a6a27a4eeb2ae24e162bcc942a6706d5 by nate.prewitt@gmail.com. The fix prevents attaching Proxy-Authorization headers to HTTPS-destined requests by adding the condition `if not scheme.startswith(\"https\")` in the rebuild_p...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2023-32681"
      },
      "impact_statement": "not_affected \u2014 CVE-2023-32681 (Proxy-Authorization header leak to HTTPS destinations) is not present in target version 2.32.3. The vulnerability was fixed upstream in v2.31.0 via commit 74ea7cf7a6a27a4eeb2ae24e162bcc942a6706d5 by nate.prewitt@gmail.com. The fix prevents attaching Proxy-Authorization headers to HTTPS-destined requests by adding the condition `if not scheme.startswith(\"https\")` in the rebuild_p..."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:pypi/requests@2.32.3.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/requests@2.32.3.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-10-29T17:24:38.799299+00:00",
      "status_notes": "Vulnerability CVE-2024-35195 does not affect version 2.32.3.post1+tuxcare of requests. not_affected \u2014 CVE-2024-35195 affects requests versions prior to 2.32.0. The target is at version 2.32.3.post3+tuxcare, which includes the upstream fix from commit c0813a2d (merged in v2.32.0). The fix modifies connection pool selection to include TLS verification settings (cert_reqs, ca_certs), preventing verify=False connections from being reused for verify=True requests. The vulnerable code pattern is not ...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2024-35195"
      },
      "impact_statement": "not_affected \u2014 CVE-2024-35195 affects requests versions prior to 2.32.0. The target is at version 2.32.3.post3+tuxcare, which includes the upstream fix from commit c0813a2d (merged in v2.32.0). The fix modifies connection pool selection to include TLS verification settings (cert_reqs, ca_certs), preventing verify=False connections from being reused for verify=True requests. The vulnerable code pattern is not ..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:pypi/requests@2.32.3.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/requests@2.32.3.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-09-24T14:43:41.647513+00:00",
      "status_notes": "Vulnerability CVE-2024-47081 affects version 2.32.3.post1+tuxcare of requests, and is fixed in 2.32.3.post3+tuxcare.",
      "vulnerability": {
        "name": "CVE-2024-47081"
      },
      "action_statement": "Vulnerability CVE-2024-47081 affects version 2.32.3.post1+tuxcare of requests, and is fixed in 2.32.3.post3+tuxcare."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:pypi/requests@2.32.3.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/requests@2.32.3.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2026-25645 affects version 2.32.3.post1+tuxcare of requests, and is fixed in 2.32.3.post2+tuxcare.",
      "vulnerability": {
        "name": "CVE-2026-25645"
      },
      "action_statement": "Vulnerability CVE-2026-25645 affects version 2.32.3.post1+tuxcare of requests, and is fixed in 2.32.3.post2+tuxcare."
    }
  ]
}
